Составить программу. существует ли треугольник со сторонами a,b,c. если да определите будет ли он прямоугольным. ( сделайте для программы: pascalabc 8 по уровню 8-ого класса)

fenziknata fenziknata    3   02.05.2019 09:05    0

Ответы
vlad270329p08pha vlad270329p08pha  09.06.2020 05:48

Var a, b, i, c:Integer ;

Begin

Write('a=') ;read(a) ;writeln;

Write('b=') ;read(b) ;writeln;

Write('c=') ;read(c) ;writeln;

If (a<c+b) and(b<a+c) and(c<b+a) then begin

I:=1;

Write(' Треугольник существует ') ;

End Else begin

I:=0;

Write(' Треугольник не существует ') ;

End;

If i=1 then begin

If (a>b) and(a>c) then

If sqr(a) =sqr(b) +sqr(c) then write(' Треуголинк прямоугольный')

Else write(' Треугольник не прямоугольный ') ;

If (b>a) and(b>c) then

If sqr(b) =sqr(a) +sqr(c) then write(' Треуголинк прямоугольный')

Else write(' Треугольник не прямоугольный ') ;

If (c>a) and(c>b) then

If sqr(c) =sqr(b) +sqr(a) then write(' Треуголинк прямоугольный')

Else write(' Треугольник не прямоугольный ') ;

End;

End.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика