Составить программу сортировки 2-х переменных по убыванию, письменно. на pascal

vikaapostol28 vikaapostol28    1   01.10.2019 18:30    0

Ответы
eryana eryana  09.10.2020 10:07

var a,b:real;

begin

readln(a,b);

if a>b then writeln(a,' ',b)  

else writeln(b,' ',a);

end.

ПОКАЗАТЬ ОТВЕТЫ
Dinozavrik2525 Dinozavrik2525  09.10.2020 10:07
PascalABC.NET 3.4.2, сборка 1864 от 11.11.2018Внимание! Если программа не работает, обновите версию!

begin

 var (a, b) := ReadReal2('Введите через пробел два числа;');

 if a < b then Swap(a, b); // a - всегда не меньше b

 Print('По невозрастанию:', a, b)

end.

Пример:Введите через пробел два числа; 3.6 10По невозрастанию: 10 3.6
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика