Составить программу сокращения одномерного числового массива путем удаления а) всех элементов с нулевыми значениями дополнительный массив использовать не ! , а то !

kolitka1 kolitka1    3   01.04.2019 10:20    2

Ответы
Эрбол11111 Эрбол11111  07.06.2020 04:59

var

  a : array [1..100] of integer;

  i, next, n : integer;

begin

  read (n);

  for i := 1 to n do read (a[i]);

  next := 1;

  for i := 1 to n do

    if a[i] <> 0 then

    begin

      a[next] := a[i];

      next := next + 1;

    end;

  n := next - 1;

  for i := 1 to n do

    write (a[i], ' ');

end.

 

В результате работы в N будет лежать новая длина, а после массива - будет лежать всяий мусор (огрызок прежднего массива), но это неважно.

  

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика