Составить программу, проверяющую, является ли заданное натуральное число совершенным, т.е. равным сумме своих положительных делителей, кроме самого этого числа. на с++, с цикла с предусловием или постусловием.

moonlight121 moonlight121    3   24.09.2019 09:10    0

Ответы
Заноза19 Заноза19  08.10.2020 14:42
#include <iostream>
using namespace std;
int main(){    int i, num, sum;        sum = 0;    i = 1;    cin >> num;    while (i < num)    {        if (num % i == 0)        {            sum += i;        }        i++;    }    if (sum == num) {        cout << sum;    }    return 0;}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика