Составить программу получающую на входе целое число a. Если a меньше 0, тогда a:=a+3, иначе a:=a-1. Какой результат выдаст программа при a = 0, a = -5, a=5?
Составить программу в паскаль, если можно то скрином из паскаля!

малый6 малый6    3   30.03.2020 14:46    15

Ответы
ImVadimka ImVadimka  12.10.2020 09:16

var

 a: integer;

begin

 Read(a);

 if a < 0 then a := a + 3 else a := a - 1;

 Writeln('Конечный результат', a);

end.

Тестовое решениеЖ

Введите А := 0

Конечный результат-1

Введите А  -5

Конечный результат-2

Введите А  -5

Конечный результат 4

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика