Составить программу поиска больших чем соседние элементов массива l из 16 чисел. значения элементов массива рассчитать по формуле cosd/d,где d номер элемента массива.

zlataaug zlataaug    3   29.05.2019 17:00    0

Ответы
Анастасия1708035 Анастасия1708035  01.10.2020 14:14
VAR
   i: Integer;
   a: Array [1..16] of Real;
BEGIN
    For i := 1 to 16 do begin
        a[i] := Cos(i) / i;
        Writeln('L[',i,'] = ',a[i]); End;

    Writeln;
    For i := 2 to 15 do
        If (a[i] > a[i-1])and(a[i] > a[i+1]) then Writeln('L[',i,'] = ',a[i]);
END.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика