tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу по вычислению
Составить программу по вычислению нок и нод на pascal
MaiorPeZDoBi4
2 15.09.2019 22:40
0
Ответы
alazaryana0707
26.08.2020 21:29
// PascalABC.NET 3.3, сборка 1611 от 06.01.2018
// Внимание! Если программа не работает, обновите версию!
function GCD_LCM(a,b:integer):(integer,integer);
begin
var c:=a*b;
while b>0 do (a,b):=(b,a mod b); // a - НОД
Result:=(a,c div a)
end;
begin
var (a,b):=ReadInteger2('Введите два натуральных числа:');
var (НОД,НОК):=GCD_LCM(a,b);
Writeln('НОД = ',НОД, ', НОК = ',НОК)
end.
Пример
Введите два натуральных числа: 13624 320
НОД = 8, НОК = 544960
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
agargo228
02.09.2019 11:20
Дан массив размера n. вывести вначале его элементы с четными индексами, а затем — с нечетными...
vika1722
07.10.2019 18:40
Сколько нулей в двоичной записи 723 (10)...
outoforder
07.10.2019 18:40
Заданы три числа x, y, z. если z 0 ,то p задать как максимальное из x и y. если z =0, то р задать как минимальное из x, y. написать на c++...
89286666666
07.10.2019 18:40
44) в корзине лежит a красных и b синих шаров. из корзины наугад вынимают n шаров. требовалось написать программу, которая определяет количество вариантов такого опыта...
vani2006
07.10.2019 18:40
Напишите код программы, которая запрашивает 2 числа, вычисляет их сумму, а затем сумма удваивается и выводится на экран. была бы за скорую ...
dzubaliz
07.10.2019 18:40
1)var d,n: integer; begin d: =5; d: =d-3; for n: = 1 to 4 dod: =d+n; writeln(d); end.2)far f,n: integer; beginf: =4; f: =f*3; for n: = 1 to 4 dof: =f+n; writeln(d); end....
123настюша321
12.05.2021 12:58
С КОНТРОЛЬНОЙ РАБОТОЙ ПО ИНФОРМАТИКЕ. У МЕНЯ ОСТАЛОСЬ 20 МИНУТ НА ВЫПОЛНЕНИЕ...
sereja2002g
12.05.2021 12:57
Какие файлы называются файлами общего доступа?...
Mrrezed
19.05.2020 15:35
Офф и он это что и как off and on...
yuli200
12.06.2019 22:40
Утроенная сумма трех последовательных чисел равна 18. найти эти числа...
Популярные вопросы
Пусть x0- наименьший положительный корень уравнения cos^2x- 5sin xcos...
2
Решите )) паскаль: в одномерном массиве произвольных чисел требуется...
2
Вычислите объем кислорода который может быть получен из 450 л воздуха...
2
На циклический алгоритм microsoft visual studio c#в каких двузначных...
1
Какой тип жилкования имеют широкие листья хвойных?...
1
А) 1-пентин обработайте 1 моль водорода. полученный продукт полимиризуйте.б)...
2
Не со словом пишется слитно в предложения : 1)эта (не)приятная надолго...
1
Вычислить неопределенный интеграл ( x^2-3)lnx dx...
1
Найти производную третьего порядка y=3x^+cos5x...
3
Из 25 вопросов экзамена студент не знает 2.какова вероятность того,что...
2
// Внимание! Если программа не работает, обновите версию!
function GCD_LCM(a,b:integer):(integer,integer);
begin
var c:=a*b;
while b>0 do (a,b):=(b,a mod b); // a - НОД
Result:=(a,c div a)
end;
begin
var (a,b):=ReadInteger2('Введите два натуральных числа:');
var (НОД,НОК):=GCD_LCM(a,b);
Writeln('НОД = ',НОД, ', НОК = ',НОК)
end.
Пример
Введите два натуральных числа: 13624 320
НОД = 8, НОК = 544960