Составить программу по нахождению стороны равностороннего треугольника по периметру. что я сделал не так?

Анна0809 Анна0809    3   19.03.2019 16:21    1

Ответы
JetMinegrifer JetMinegrifer  26.05.2020 04:45

Переменные с типом integer нельзя делить. Надо вместо integer в разделе var поставить real

ПОКАЗАТЬ ОТВЕТЫ
JICNX JICNX  26.05.2020 04:45

У равностороннего треугольника все стороны равны, а значит Р=3а, > а=Р/3

Естественно, как указано ниже, а- вещественные число, а Р принимает только целые значения, ибо при выполнения программы компьютером возникнет ошибка.

Program Long side ;

Var a:real;

Var P:Integer;

Begin

Write ("Perimeter of the equilateral triangle") ;

Read(P)

a:=P/3;

Write("The Length Of the equilateral triangle side is equal to" a) ;

end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика