Составить программу печатающие числа от -50 до 50 в обратном порядке,увеличивающее каждое число в 10 раз.

крик56 крик56    3   03.03.2019 21:50    3

Ответы
klemeshova1989 klemeshova1989  24.05.2020 00:40

program;

var

max,val: integer;

label

start, ends; 

begin 

max:=-50;

val:=50;

start:

if val>max then val:=val-10

if val=max then goto ends; 

goto start; 

ends:

end. 

ПОКАЗАТЬ ОТВЕТЫ
EllenOnyschuk EllenOnyschuk  24.05.2020 00:40

Вот на C:

 

#include <stdio.h>

int main(void)
{
  int i;
  for(i = 50; i >= -50; i -= 10)
  {
   printf("%d\n", i); 
  }

  printf("\n");
  system("pause");
  return 0;
}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика