Составить программу определения задуманного человеком числа от 1 до 1000 с 10 вопросов. каждый вопрос имеет вид: задуманное число больше к? (входные данные: > ответы : да(1), нет(0).

Андрій008695652945 Андрій008695652945    2   01.06.2019 13:30    3

Ответы
mstrager2342 mstrager2342  02.07.2020 17:11
Пробовал, решить невозможно, или я такой дуболом.
Для определения числа в разряде десятков, нужно как минимум 9 вопросов.
Спрашивая "Больше ли оно K" - добиться этого невозможно.
Но могу подсказать начало :)

program dlya_Pro100LiNa;
var a,b,c,d:integer;
m:boolean;
begin
writeln ('Введите число от 1-го до 1000');
repeat read(a) until (a>=1)and(a<=1000);
...
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика