Составить программу, объясните. ввести двухзначное число. если сумма цифр числа четная, то увеличить число на 2, в противном случае уменьшит на 2

vita102003 vita102003    2   01.10.2019 04:30    146

Ответы
Podokonik Podokonik  09.10.2020 07:01

Объясняю: создаёте переменную, лучше целочисленную (int foo), после чего можно либо перевести число в строку и найти сумму цифр путём сложения двух символов (sum = bar[0] - '0' + bar[1] - '0'), либо с остатка от деления (конечно, это не очень красиво, но если известно, что число двузначное, то можно так: sum = (foo / 10) + (foo % 10)). Дальше банальная обработка условия: <если сумма чётная (if (sum % 2 == 0)), то увеличить число на 2 (foo += 2), иначе (else) уменьшить число на 2 (foo -= 2)>. После этого можете вывести результат на монитор (printf("%d\n", &sum)). :)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика