Составить программу нахождения для заданного натурального числа n всех делителей, кратных числу c. формат входных данных входной файл содержит числа n, c (1≤n,c≤1000). формат выходных данных выведите искомые делители. примеры: вход 6 3 выход 3 6 вход 4 15 выход

anastasia559 anastasia559    1   26.09.2019 22:20    4

Ответы
Алёна345135537 Алёна345135537  08.10.2020 21:14

Язык С++

#include <iostream>

using namespace std;

int main(){

int N,C;

cin>>N>>C;

for(int i=1;i<=N/C;i++)

if(N%(i*C)==0)

cout<<i*C<<" ";

return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика