tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу на
Составить программу на языке си известны год и номер месяца рождения человека. определить возраст человека на март(3 месяц) 2008 года
vvvvsidorina
3 18.08.2019 19:30
1
Ответы
winforever
05.10.2020 03:23
#include <stdio.h>
int main() {
int year, month, cur_y = 2008, cur_m = 3, m_age, y_age;
scanf("%d%d", &year, &month);
if(month - cur_m > 0) {
m_age = 12 - (month - cur_m);
y_age = (cur_y - year) - 1;
} else {
m_age = cur_m - month;
y_age = cur_y - year;
}
printf("%d years and %d months\n", y_age, m_age);
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
elzamarg
20.04.2020 16:01
Укажите, какое логическое выражение равносильно выражению: не (не В & не C) & не А...
satursacha
20.04.2020 16:00
Черно-белое (без градаций серого) графическое изображение имеет размер 20 × 20 точек. Какой объем памяти займет это изображение?...
daryachita
25.05.2020 12:26
Итоговое тестирование информатика 5 кл. На кординатной плоскости отметьте и прономируйте точки с кординатами:А(2,1)Б(4,8),В(6,8)Г(8,1)Д(6,1)Е(5,6)Ж4,1. СОЕДИНИТЕ ТОЧКИ А, Б, В,...
avritsevich0116
18.02.2021 15:05
Який оператор реалізує дію: Якщо ціле число a парне, поділити його на 2...
sonyachu
15.09.2020 05:16
Алфавитный подход и содержательный подход,примеры из жизни(по 3-4 примера на каждый подход)...
kveresgova
01.12.2020 16:00
Постройте таблицы истинности для логических выражений: а) A ∨ B & A & ¬ Bб) (A & B) ∨ (¬ A ∨ B)...
Alino4ka58258
01.12.2020 16:01
Составьте программу на C++ записывающую элементы массива A[10] в обратном порядке.Ввод 2 6 5 9 4 8 7 1 3 2.Вывод 2 3 1 7 8 4 9 5 6 2...
elsoc
01.12.2020 16:01
Выразите в Гиб 4096 МиБ = 4096: 1024 Гиб =4 Гиб5 242 880 КИБ = 5 242 880 :5ГИБ =52 147 483648 Б2 147 488 648 -2Подсказка:Используйте таблицу производных единиц информации итаблицу...
mrsdyy
01.12.2020 16:02
Написать на Паскале программу является ли число отрицательным и не четным...
gtufifk
01.12.2020 16:03
Добавьте к программе про зарплаты следующие функции: Top3() - Топ 3 самых бедных и самых богатых людей среднее() - Среднюю зарплату и имя человека ее получающего подоходный налог()...
Популярные вопросы
Напряженность электрического поля в пространстве между платинами в вакууме равна...
1
Заполни пропуски, выбрав верный ответ из выпадающего списка: В течение месяцев...
2
На гистограмме показано распределение диаметра драже с орехами из одного большого...
2
Махаббат пен достық және сыйластық тақырыбына 6 мақал-мәтел жазыңдар можете...
2
Перепишите приведенные отрывки текстов, расставьте знаки препинания. Определите,...
2
Напишите цифры словами. Сколько раз 5 содержится в 1969?...
3
Коммерческий банк принял от акционеров - физических лиц денежные средства наличными...
3
Оба задания очень нужно сделать...
1
Для данных гормонов укажите место выработки; приведите названия, опишите химическую...
3
Тема: Синусы, косинусы,тангенсы острых углов треугольника задание: Исходя из...
1
int main() {
int year, month, cur_y = 2008, cur_m = 3, m_age, y_age;
scanf("%d%d", &year, &month);
if(month - cur_m > 0) {
m_age = 12 - (month - cur_m);
y_age = (cur_y - year) - 1;
} else {
m_age = cur_m - month;
y_age = cur_y - year;
}
printf("%d years and %d months\n", y_age, m_age);
return 0;
}