tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу на языке
Составить программу на языке паскаль ввести с клавиатуры вещественное число a и целое число n (> 0). вывести все целые степени числа a от 1 до n.
5432881
3 15.09.2019 10:40
1
Ответы
olechkapushkareva
26.08.2020 21:08
Var a,an:real; n,i:integer;
begin
readln(a,n);
an:=1;
for i:=1 to n do
begin
an:=an*a;
writeln(a:3:2,'^',i,' = ',an:6:3);
end;
end.
Пример:
2.0 5
2.00^1 = 2.000
2.00^2 = 4.000
2.00^3 = 8.000
2.00^4 = 16.000
2.00^5 = 32.000
ПОКАЗАТЬ ОТВЕТЫ
Tomoki
26.08.2020 21:08
Var
a: real;
n: integer;
begin
read(a, n);
for var k := 1 to n do
begin
write(power(a, k), ' ');
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
KseniaSamarskaia15
18.10.2019 13:21
Что делать если выскакивает ошибка c: \gamesmailru\warface\bin64release при заходе в варфейс? .windows 7 64бит.антивирус отключал,игру три раза переустанавливал....
annasavchenko5
18.10.2019 13:32
Большое количество python 3.7.4 на вход подаётся n целых чисел. числа разделены пробелами и/или строк. вашей программе требуется вывести одно целое число — сумму всех чисел во вводе....
мозг3567
18.10.2019 11:32
Javascript netbeans дана непустая последовательность натуральных чисел, оканчивающаяся нулем. найти среднее арифметическое чисел этой последовательности, не учитывая при этом завершающий...
Nastya171167
29.04.2021 15:39
Як називається цикл, в якому спочатку йде перевірка умови, а потім виконуються команди тіла циклу?...
Hapec
29.12.2021 18:42
Что я тут сделал не правельно? from random import* from tkinter import* size = 500 tk = Tk () diapasone = 0 my_canvas = Canvas (tk, width=size, height=size) my_canvas . pack () while...
LOlka228322
01.04.2020 19:57
Какой документ имеет расширение .DOCX...
0Dasha0Shevelova0
04.11.2020 07:24
МОГИТЕ Над газом была совершена работа 55 Дж, а его внутренняя энергия увеличилась на 15 Джоулей. Какое количество теплоты получил или отдал газ в этом процессе?...
ilyassovaalina235393
04.11.2020 07:24
Күкірт атомы үшін дұрыс тұжырымдарды анықтаңыз...
lyagaeva87
04.11.2020 07:24
В МИРЕ НЕТ ТАКОЙ СЕМЬИ ДИАЛОГ ЧТОБЫ Я САМА СЕБЕ ЗАДАВАЛА ВОПРОСЫ ...
Z1439373
04.11.2020 07:24
Закончите уравнения реакций, расставьте коэффициенты: Nа +О2 Н2О Н2 + ? у меня осталось 30 минут...
Популярные вопросы
Найди слова с безударной гласной в приставке.выдели её графически.накипь,нарисовал,наклон,заявка,залежи,заграничный,дословный,доверху,доверить,подбить,подбородок,подступ,отдых,отправить,отзыв,оклик,оберегать,окружность,полить,повод,пограничник....
2
Составь алгоритм решения : расположить три числа 1,7,4 в порядке возрастания....
3
Перепишите, вставляя пропущенные буквы, выделяя суффиксы причастий. графически...
3
Зделайте морфологический разбор слов: не торопливого,чистейший,серебряные,безлюдный...
1
Окружности о₁, о₂, о₃ радиусов 1, 1 и 2 см соответственно попарно касаются друг...
3
Как представлена ворона в стихотворении блока ворона ?...
3
Выразите в тенге: 5 тг 61 тн, 17 тг 36 тн, 67 тн. запишите ответ в виде десятичной...
3
На завод отправлено 3 600 т угля в вагонах,по 60 т в каждом,и столько же угля...
2
Қай жағынан оқысандар да белгілі бір мағынаны білдіреді 10-15сөз !...
1
Кенгуру и чудо склоняемые или несклоняемые существительные...
3
begin
readln(a,n);
an:=1;
for i:=1 to n do
begin
an:=an*a;
writeln(a:3:2,'^',i,' = ',an:6:3);
end;
end.
Пример:
2.0 5
2.00^1 = 2.000
2.00^2 = 4.000
2.00^3 = 8.000
2.00^4 = 16.000
2.00^5 = 32.000
a: real;
n: integer;
begin
read(a, n);
for var k := 1 to n do
begin
write(power(a, k), ' ');
end;
end.