Составить программу на языке паскаль. просто ! умоляю! 1)составить программу ввода букв или цифры,или спецзнака. выводить сообщение типа"это "," это буква..",или "это спецзнак..". к сообщению добавлять саму цифру,букву,спецзнак. 2)у белых на доске остался король,а у черных король и ферзь. охарактеризовать положение белых с одного из слов шах,мат,пат,обыкновенная позиция
const
sAlpha='';
sDigit='0123456789';
var
c,c1:char;
begin
Write('Введите символ: '); Readln(c);
c1:=LowerCase(c);
if Pos(c1,sAlpha)>0 then Writeln('Введена буква ',c)
else
if Pos(c1,sDigit)>0 then Writeln('Введена цифра ',c)
else Writeln('Введен спецсимвол ',c)
end.
Программирование задачи №2 - большая работа, требующая многих часов, если не имеется готовых наработок для программирования шахматной игры. Давать подобные задачи для решения на данном Сервисе - бесполезное занятие, такое не задают даже на олимпиадах.