Составить программу на языке паскаль, которая запрашивает у пользователя некоторое количество трехзначных чисел и выводит на экран цифру, находящуюся в середине каждого полученного числа. не в коем случае не используй их: last, const, count. делай обыкновенным

JuMpEr104 JuMpEr104    3   23.09.2019 06:40    0

Ответы
blowwwwwwww blowwwwwwww  16.08.2020 21:00
Var i, x, y: integer;

a: array [1..255] of integer;
function sr(i: integer):string;

begin

sr:=inttostr(i)[2];

end;
begin

writeln('Vvedite kol-vo chisel');

read(x);

for i:=1 to x do read(a[i]);

writeln();

for i:=1 to x do writeln(sr(a[i]));

end.
ПОКАЗАТЬ ОТВЕТЫ
Дерюгин Дерюгин  16.08.2020 21:00
Program n_5;
var
   a, b, c: real;
procedure n_1;
begin
 if ((a<b) and (a>c)) or ((a<c) and (a>b)) then
  write (a)
 else
  if ((b<a) and (b>c)) or ((b<c) and (b>a)) then
   write (b)
  else
   if ((c<a) and (c<b)) or ((c<b) and (c>a)) then
    write (c);
end;
begin
 writeln ('Введите три трёхзначных числа');
 readln (a);
 readln (b);
 readln (c);
 if ((a >= 100) and (a <= 999) and (a <> b) and (a <> c)) and ((b >= 100) and (b <= 999) and (b <> a) and (b <> c)) and ((c >= 100) and (c <= 999) and (c <> a) and (c <> b)) then n_1
 else
  write ('ERROR');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика