Составить программу на языке паскаль: две точки своими координатами. определите, какая из них находится дальше от: начала координат; окружности заданного радиуса с центром в начале координат.

Сонька766 Сонька766    1   16.06.2019 01:20    1

Ответы
tim1415320053774 tim1415320053774  12.07.2020 22:58
Program gt;
var x1,y1,x2,y2,r:real;
begin
readln(x1,y1,x2,y2);
readln(r);
if((sqr(x1)+sqr(y1))<(sqr(x2)+sqr(y2)))then writeln('Pervaya')else
writeln('2-raya');
if(abs(sqrt(sqr(x1)+sqr(y1))-r)<abs(sqrt(sqr(x2)+sqr(y2))-r))
then writeln('Pervaya-ornositelno okru') else writeln('2-raya otnositelno okru');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика