составить программу на СИ, пользователь вводит строку, в которой все заглавные символы которые он введёт будут преобразованы в прописные

temik2005ap08ttx temik2005ap08ttx    2   12.11.2020 21:40    4

Ответы
Masha04131 Masha04131  12.12.2020 21:45

Код программы:

#include <locale>

#include <stdio.h>

int main() {

setlocale(LC_ALL, "Russian");

char str[500];

int i;

printf("Введите строку:\n");

fgets(str, 500, stdin);

for (i = 0; i < strlen(str); i++) {

 if (isupper(str[i]))

  str[i] = tolower(str[i]);

}

printf("\nПреобразованная строка: %s", str);

       return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика