Составить программу на паскаль: рассчитать радиус окружности, вписанной в треугольник r1= s/p и описанной вокруг треугольника r2= a*b*c/(4*s), где s - площадь, а p - полупериметр треугольника. a, b, c - стороны треугольника ( исходные данные ).

TupouChuBaK TupouChuBaK    1   01.07.2019 09:30    2

Ответы
AnnKJ AnnKJ  02.10.2020 17:20
Находим периметр p=a+b+c, затем полупериметр p_2=p/2, и далее по формуле Герона площадь S.
S=\sqrt{p_2(p_2-a)(p_2-b)(p_2-c)}

var
  a,b,c,p,s,p2,r1,r2:real;
begin
  Write('Введите стороны треугольника: ');
  Read(a,b,c);
  p:=a+b+c; p2:=p/2;
  s:=sqrt(p2*(p2-a)*(p2-b)*(p2-c));
  r1:=s/p; r2:=a*b*c/(4*s);
  Writeln('R1=',r1,', R2=',r2)
end.
 
Тестовое решение:
Введите стороны треугольника: 4 6 7
R1=0.704502327470793, R2=3.50685603007684
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика