Составить программу,которая заполняет массив a(1..20) случайными числами [-2; 2]вычислить произведение отрицательных элементов массива с индексами от n до m включительно(n,m вводятся с клавиатуры)
//PascalABC.NET версия 3.3.1590 от 03.12.2017 //Если программа не запускается, то обновите версию begin var a := ArrRandomInteger(20, -2, 2); Writeln(a); var n := ReadInteger('n='); var m := ReadInteger('m='); a := a.Skip(n - 1).Take(m - n).ToArray(); Writeln(a); if a.Any(x -> x < 0) then writeln(a.Where(x -> x < 0).Aggregate(1, (x, y)-> x * y)); end.
//Если программа не запускается, то обновите версию
begin
var a := ArrRandomInteger(20, -2, 2);
Writeln(a);
var n := ReadInteger('n=');
var m := ReadInteger('m=');
a := a.Skip(n - 1).Take(m - n).ToArray();
Writeln(a);
if a.Any(x -> x < 0) then
writeln(a.Where(x -> x < 0).Aggregate(1, (x, y)-> x * y));
end.