Составить программу, которая заполнит массив по правилу:
(числа от 1 до 30)


Составить программу, которая заполнит массив по правилу:(числа от 1 до 30)

мик271 мик271    3   08.12.2020 06:33    2

Ответы
МиллкаВах МиллкаВах  07.01.2021 06:35

#include <iostream>

#include "string.h"

#include "stdlib.h"

using namespace std;

int main()

{

setlocale(LC_ALL, "rus");

int x; int mas1[30];

for (int i = 0; i < 15; i++) {

 x = rand() % 10;

 mas1[i] = x * x + 4;

}

for (int i = 15; i < 30; i++) {

 x = rand() % 10;

 mas1[i] = 3 * x - 10;

}

for (int i = 0; i < 30; i++) {

 cout << mas1[i] << "\n";

}

}

Объяснение:

числа псевдорандомные от 0 до 10

ПОКАЗАТЬ ОТВЕТЫ
natochka2001 natochka2001  07.01.2021 06:35

program massiv;

var i: integer;

mas: array[1..30] of integer;

begin

 for i:= 1 to 30 do

 begin

   if i < 16 then

     mas[i]:= sqr(i) + 4

   else

     mas[i]:= 15*(3*i-10);

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика