Составить программу которая вычисляет произведение членов последовательности n натуральных чисел, кратных 5. программа получает на вход целые числа, количество введеных чисел неизвестно, последовательность заканчивается числом n.

сдаддае сдаддае    1   22.07.2019 02:50    1

Ответы
az0967848 az0967848  03.10.2020 10:14
В условии задачи есть противоречие: с одной стороны количество чисел = N, а с другой - количество неизвестно, а дается признак конца последовательности. Программа дана для 2-го варианта.
var n,a:integer; p:real;
begin
write('n = '); readln(n);
write('a = '); readln(a);
p:=1;
while a<>n do
 begin
 if a mod 5 = 0 then p:=p*a;
 write('a = '); readln(a);
 end;
writeln('p = ',p);
end.

Пример:
n = 999
a = 6
a = 10
a = 24
a = 15
a = 56
a = 7
a = 5
a = 999
p = 750
ПОКАЗАТЬ ОТВЕТЫ
алиса769 алиса769  03.10.2020 10:14
Мой милорд, прибыли поставки в виде решения
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика