Составить программу, которая определяет, принадлежит ли заданное число отрезку [0; 2]. на языке pascal, pascalabc.net

12oskar12oskar 12oskar12oskar    2   16.08.2019 06:20    2

Ответы
revati1 revati1  04.10.2020 22:25
1. PascalABC.NET

// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var x:=ReadReal('Введите число:');
  Writeln((x>=0) and (x<=2)?'Да':'Нет')
end.

Пример
Введите число: 1.17
Да

2. На этой же версии в стиле традиционного школьного паскаля

var
  x:real;
begin
  Write('Введите число: '); Read(x);
  if (x>=0) and (x<=2) then Writeln('Да')
  else Writeln('Нет')
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика