tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу,которая формирует
Составить программу,которая формирует список l, включив в него по одному разу элементы,которые входят одновременно в оба списка l1 и l2. pascal abc.net
olesyasa1
1 12.07.2019 00:30
6
Ответы
Niker04
03.10.2020 01:32
// PascalABC.NET 3.0, сборка 1088
begin
var L1:=new List<integer>;
L1.AddRange(SeqRandom(15,-20,20));
Writeln('Список L1'); Writeln(L1);
var L2:=new List<integer>;
L2.AddRange(SeqRandom(10,-5,40));
Writeln('Список L2'); Writeln(L2);
var L:=new List<integer>;
L.AddRange(L1.Intersect(L2).Distinct);
Writeln('Список L'); Writeln(L);
end.
Тестовое решение:
Список L1
[8,7,-13,0,12,-1,3,5,-15,13,18,-10,16,14,-1]
Список L2
[31,37,25,13,2,14,5,8,10,34]
Список L
[8,5,13,14]
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
микки37
28.09.2019 15:01
Какие информационные носители вы используете в жизни?...
Рабка
23.05.2020 17:25
Как осуществить настройку браузера Internet Explorer ?...
trixi1989vv
22.05.2020 17:02
УКАЗАНИЯ ПО ВЫПОЛНЕНИЮ 1. Составьте макрос, который запрашивает по отдельности день, месяц и год, затем из введенных значений формирует текстовую строку (например,...
TheDanilDid
22.05.2020 17:02
ПАМАГИТЕ Уровень A. Перейдите на Лист 1 и постройте таблицу истинности логической функции F = (A и не B) или C Уровень B. Перейдите на Лист 2 и постройте таблицу...
ritababak
23.05.2020 16:37
Приведите не менее 5 моделей объектам : А) кот Б) телевизор...
jenja117
23.05.2020 16:37
Вот ссылка на скачивание Raid: Shadow Legends. Перейди по ней, установи игру – и мы оба получим крутые подарки умоляю тебя...
hatasa75
23.05.2020 16:37
Дано: for i : = 1 to 36 doПри последнем выполнении тела цикла i =...
Andrew12331
23.05.2020 16:37
В электронной таблице ячейкой называют...
egorkovalev000007
22.05.2020 18:29
СОСТАВИТЬ ТАБЛИЦУ РЕЗУЛЬТАТОВ ПО БЛОК СХЕМЕ...
megan99
22.05.2020 18:28
Напишіть програму мовою програмування Паскаль, яка обчислює приклад 8v+18k/t^2 (це t в квадраті)...
Популярные вопросы
Слово кров проверочное слово найти к нему...
1
Решить уравнение (во вложении) ответ записать по образцу: a;...
2
Найти многочлен наименьшей степени, среди корней которого есть...
1
Встоловую 4 ящика помидоров по 8 килограмм в каждом и б ящиков...
1
Составить предложение про реку и город...
3
Школьники посадили 16 саженцев рябины сирени на...
3
А) найдите 2/13 от суммы чисел 31(3/2) и 51(1/8). б) найдите...
3
Выразите число 8\27 и 2\9\34 в виде приблежённого значения десятичной...
2
Вспортивных соревнованиях участвовали 18 человек, что состовляет...
3
Два станка - автомата за 1час совместной работы изготовили 250...
3
begin
var L1:=new List<integer>;
L1.AddRange(SeqRandom(15,-20,20));
Writeln('Список L1'); Writeln(L1);
var L2:=new List<integer>;
L2.AddRange(SeqRandom(10,-5,40));
Writeln('Список L2'); Writeln(L2);
var L:=new List<integer>;
L.AddRange(L1.Intersect(L2).Distinct);
Writeln('Список L'); Writeln(L);
end.
Тестовое решение:
Список L1
[8,7,-13,0,12,-1,3,5,-15,13,18,-10,16,14,-1]
Список L2
[31,37,25,13,2,14,5,8,10,34]
Список L
[8,5,13,14]