Составить программу которая формирует массив из 9 случайных целых чисел на промежутке от -30,30 и вычислите: а) сумму отрицательных чисел б) произведение чётных чисел
Var mas: array [1..9] of integer; summ, count: integer; i: integer; begin randomize; summ := 0; count := 1;
for i := 1 to 9 do begin mas[i] := random(-30, 30); write(mas[i] : 4); if mas[i] < 0 then summ := summ + mas[i]; if mas[i] > 0 then count := count * mas[i]; end;
mas: array [1..9] of integer;
summ, count: integer;
i: integer;
begin
randomize;
summ := 0;
count := 1;
for i := 1 to 9 do
begin
mas[i] := random(-30, 30);
write(mas[i] : 4);
if mas[i] < 0 then summ := summ + mas[i];
if mas[i] > 0 then count := count * mas[i];
end;
writeln('');
writeln('Сумма отрицательных элементов: ', summ);
writeln('Произведение положительных элементов: ', count);
end.