Составить программу ,которая будет выдавать последовательность квадратов натуральных чисел от 1 до n, где n вводится с экрана.заранее

Silvertrue Silvertrue    3   21.09.2019 08:01    1

Ответы
olenapolova4 olenapolova4  08.10.2020 06:39
PascalABC.NET 3.3.5, сборка 1640 от 17.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  1.To(ReadInteger('n=')).Select(t->t*t).Println
end.

Пример
n= 30
1 4 9 16 25 36 49 64 81 100 121 144 169 196 225 256 289 324 361 400 441 484 529 576 625 676 729 784 841 900
ПОКАЗАТЬ ОТВЕТЫ
oksiz72 oksiz72  08.10.2020 06:39
var x,n: integer;
begin
write('n = ');
readln(n);
     x := 1;
while sqr(x) < n do begin write(sqr(x),' ');
         x := x + 1 end;  
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика