Составить программу, используя двумерный массив: Рассчитать сумму положительных нечетных элементов матрицы​
(Pascal)

natasha20042 natasha20042    2   28.01.2021 00:22    1

Ответы
Неизвестная66 Неизвестная66  27.02.2021 00:26

var

 a: array[,] of integer;

 m, n, i, j, sum: integer;

begin

 Write('Введите размер матрицы M и N: '); ReadLn(m, n);

 SetLength(a, m, n);

 randomize;

 WriteLn('Массив:');

 for i := 0 to m - 1 do

 begin  

   for j := 0 to n - 1 do

   begin

     a[i, j] := random(200) - 100;

     Write(a[i, j]:4);

     if (a[i, j] > 0) and (a[i, j] mod 2 = 1) then sum := sum + a[i, j];

   end;

   WriteLn;

 end;

 WriteLn('Сумма положительных нечетных элементов матрицы равна ', sum);

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика