tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу формирующую
Составить программу формирующую двухмерный массив 10^10 заполненный нулями,затем вывести на экран,затем преобразовать таким образом чтобы элементы главной диагонали были равны 1
ьпоаь1
3 15.06.2019 12:40
0
Ответы
lckzgizigzly
12.07.2020 16:56
Program array
var
i,j:integer;
a: array [1..10, 1..10] of integer;
begin
for i:=1 to 10 do begin
for j:=1 to 10 do begin
a[i,j] = 0;
writeln(a[i,j],"\t");
end;
end;
for i:=1 to 10 do begin
for j:=1 to 10 do begin
if (i = j) then a[i,j] = 1;
writeln(a[i,j],"\t");
end;
end;
end;
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Настюша1118
05.10.2019 12:40
Вклассе 35 учеников, каждый из них играет в футбол, волейбол, баскетбол, а некоторые из них играют в два или даже три из этих видов спорта. 24 ученика играют в футбол, 18 – волейбол,...
Вероника1306
05.10.2019 12:40
Особенности языков символического кодирования?...
romanchuknina
28.09.2019 18:30
Чем отличается электронная почта от обычной? в чем сходство?...
katesgo
04.05.2020 06:29
заполните таблицу Проект «Поход в магазин» Сегодня у Динары день рождения. К ней в гости придут друзья. Чтобы угостить гостей, Динаре нужно сходить в 2 магазина возле дома. Расстояние...
stacezoloto
04.05.2020 04:59
Встречено function , а ожидался оператор function F(n: integer): integer; begin if n 1 then F := F(n - 1) + G(n - 1) else F := 2*n; end; function G(n: integer): integer; begin if...
guljanatkabdrasheva
13.07.2020 20:24
Знания об окружающем мире называют a) информацией b) действием c) предметом...
TheEnder
04.10.2019 00:10
Дан массив. все элементы меньше 10 умножить на 100. , (это в паскали) 30...
Kolyakek
04.10.2019 00:10
Уфальшивомонетчика есть семь одинаковых по виду серебряных монет и две одинаковые по виду золотые монеты. внешне монеты из разного металла различаются. настоящие монеты из одного...
Катя092006
03.10.2019 23:02
Кумир 8 класс информатика. решить 3 , 80 ....
Nastya152018
04.10.2019 00:10
Сложить все числа массива больше 30 , нужно ( 30 )...
Популярные вопросы
Написать твір ти не молися мовою чужою,бо на колінах стоячи умреш...
1
Как решить это уравнение? х: 7=210: 3...
3
Морфолагичиский разбор слова словесность...
1
Мише 10 лет. его дедушка в 6 раз старше миши, а бабушка на 4 года моложе дедешки....
1
1,41993: 3,506-0,8118: 2,05-0,135: 15...
3
Зависит ли площадь круга от его радиуса? какой вид имеет эта зависимость? определите...
2
Сравнить числа : а)1\3 и0,3; б)1\3 и 0,(3);...
3
Как написать в циврах: четыреста двадцать три миллиарда триста сорок милионов...
3
Доклад про владимира ивановича даля как о языковеде...
1
Айгерим нашла 22 белых гриба из них 6 грибов она отдала брату а 8 грибов подруге...
3
var
i,j:integer;
a: array [1..10, 1..10] of integer;
begin
for i:=1 to 10 do begin
for j:=1 to 10 do begin
a[i,j] = 0;
writeln(a[i,j],"\t");
end;
end;
for i:=1 to 10 do begin
for j:=1 to 10 do begin
if (i = j) then a[i,j] = 1;
writeln(a[i,j],"\t");
end;
end;
end;