tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу для вычисления
Составить программу для вычисления суммы факториалов всех четных чисел от m до n.(matlab)
wjruwhtu
1 12.09.2019 06:10
0
Ответы
vitaliy000007
07.10.2020 09:04
Var
i,m,n,s:integer;
function fact(a:integer):integer;
var l:integer;
begin
l:=1;
for i:=2 to a do
l:=l*i;
fact:=l;
end;
begin
read(m);
readln(n);
s:=0;
for i:=m to n do
if i mod 2=0
then s:=fact(i)+s;
writeln('Suma: ',s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
vovanharahashyox7cel
28.05.2019 02:00
1)написать программу вывода всех четных чисел от 2 до 1000 включительно 2)написать программу определяющую сумму всех нечетных чисел от 1 до 99...
mirankov
28.05.2019 01:50
1)10011011,011 + 1111100001,0011 ( двоичная система счисления )...
Владушкаcat
27.10.2020 08:22
Постройте таблицу истинности ! ...
АнастейшаГрей1
27.10.2020 08:22
При кодировке текстового сообщения, состоящего из 70 символов, потребовалось 560 бит, а при дальнейшем изменении кодировки на другую его итоговый объем составил 70 байт. Какое...
slender24
27.10.2020 08:21
У меня СОР заранее. Хорошего дня...
Mikich2
29.07.2019 14:20
Напишите программу, которая находит минимальный и максимальный элементы из элементов матрицы с четными положительными значениями и их индексы. учтите, что таких элементов в матрице...
xxx158
11.08.2019 08:30
Какая субд установлена на компьютерах в вашем классе?...
Subaruworld
11.08.2019 08:30
Синформатикой (программирование на языке pascalabc.net).нужно создать программу вычислите площадь кольца введите исходные данные радиус кольца - 3.5 радиус отверстия (см)- 7 ошибка!...
даня1003
02.10.2019 15:17
Гоночный автомобиль разгоняется до скорости 108км/ч за 3,4с. определить ускорение и пройденный путь при разгоне, скорость 10с. после разгона ...
NoName2281111
02.10.2019 16:20
Твір-роздум чи легко бути дорослим? іть...
Популярные вопросы
Кто виноват в ссори мальчика и дяди? рассказ цифры...
2
Виконайте звуковий запис слів пень,джміль,щастя...
2
Социальные группы, понятия, отличия, их классификация...
3
Вычислите,, с решениями (не просто ответ) ! 200 780 - 415 * 50 + 12 220 = 10...
2
Какие обстоятельства жизни и.тургенева отразились в словах о языке : ты один...
2
Что будет если в тарелку с водой налить подсолнечное масло желательно...
2
Нужны признаки земноводных.заранее !...
1
Rewrite the sentences beginning with underlined words. active and passive voice....
3
Из слов зима , снег ,пушистый составить два предложения (можно добавлять другие...
2
Чому цукор швидше розчиняєтся у теплій воді ніж у холодній...
1
i,m,n,s:integer;
function fact(a:integer):integer;
var l:integer;
begin
l:=1;
for i:=2 to a do
l:=l*i;
fact:=l;
end;
begin
read(m);
readln(n);
s:=0;
for i:=m to n do
if i mod 2=0
then s:=fact(i)+s;
writeln('Suma: ',s);
end.