Составить программу для вычисления f=c+(a+b)/(a*b+1) a-наименьший элемент массива; в-количество отрицательных элементов массива; с-количество элементов массива, меньших d(вывести d с клавиатуры). полученные значения элементов a,b,c,f, вывести на печать.
v:array[1..10]of integer;
f:real;
i:byte;
a,b,c,d,min,k:integer;
begin
for i:=1 to 10 do
v[i]:=random(20)-10;
readln(d);
min:=v[1];
b:=0;
for i:=1 to 10 do begin
if v[i]<0 then begin
b:=b+1;
end;
if v[i]>min then
a:=min;
end;
k:=0;
for i:=1 to 10 do begin
if v[i]<d then
k:=k+1;
end;
c:=k;
writeln('наименьший элемент =', a);
writeln('количество отрицательных элементов =', b);
writeln('количество элементов меньших d =', c);
f:=c+(a+b)/(a*b+1);writeln(f);
end.