tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составить программу для сортировки
Составить программу для сортировки методом сплошного просмотра по убыванию произвольного массива g(n). отсортировать массив а(10) методом пузырька по возрастанию. =***
sonyasm2006
3 19.06.2019 17:20
0
Ответы
vipkakunina
02.10.2020 05:33
Исходный код на С++:
#include <iostream>
using namespace std;
int main()
{
int size;
cin >> size;
int *a = new int[size];
for (int i = 0; i < size; i++)
{
cin >> a[i];
}
for (int i = 0; i < size; i++)
{
for (int j = size - 1; j > i; j--)
{
if (a[j] < a[j - 1])
{
swap (a[j], a[j - 1]);
}
}
}
for (int i = 0; i < size; i++)
{
cout << a[i] << ' ';
}
return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
hohodge
27.02.2021 18:48
Напечатайте то что я показал на картинке выше...
мпрьььоппааамт
27.02.2021 18:41
3. Судьи поставили спортсмену оценки: 5.9, 5.85, 6.0, 5.95, 6.1, 5.9. Найдите средний . Выразитецелым числом а программе python...
Asil1231
05.01.2021 16:17
1. На месте преступления были обнаружены четыре обрывка бумаги, на которых записаны фрагменты одного IP-адреса. Восстановите IP-адрес. А 19 Б 6.197 В 3.12 Г .209 2. Доступ к...
ffh5
05.01.2021 16:22
«Запись исходного кода программы на С++» Надо: 1. Организовать ввод строки 2. Подсчитать кол-во слов и вывести на печать. 3. Удалить слова «Запись» и «исходного» 4. Если первая...
ЕваЛя
05.01.2021 16:23
Объём сообщения состовляет 50 байт Текстовое сообщение содержит 80 символов Сколько букв алфавита было использовано?...
steshina27
05.01.2021 16:26
Один символ текста занимает объём 4 бит на диске выделено 80 байт сколько символов можно записать на диск хелп...
ДичьМэн
05.01.2021 16:42
Умножение многочленов алгоритмом Карацубы КОД НА С++ НЕ ПЫТАЙТЕСЬ ПИСАТЬ БРЕД...
kik678
30.08.2019 20:50
Книга набранная с компьютера содержит 130 страниц, на каждой странице 55 строк, в каждой строке 15 символов, каков объем информации в кб?...
rhejjsxn
15.02.2020 11:54
Укажите количество целых чисел в диапазоне от 20o до 300 (включительно), таких, что остаток от деления суммы четных цифр числа на 8 равен 6....
BackedSmile
15.02.2020 11:49
. Количество повторений цикла где начальное значение х=1, а конечное=9, х меняется с шагом h=1 будет: а. 1 б. 9 в. 4,5 г. 5 2. При нахождении суммы ряда, при том, что «s» это...
Популярные вопросы
Для прямо порпорцеональнои зависимости у=Rx наидите значение R если y(-0,7)=70;...
3
Противоложные числа 3/5, -20...
3
Personality - a concept developed to reflect the nature of a person, consider...
2
Какое впечатление произвёл на вас Хорошее дело?(8 предложений, с использованием...
3
Напишите сочинение Как правильно ржать по туповедению. Даю 28(14) . Очень...
2
Напишите конспект про аварию на Чернобыльской АС : дата, причина, последствия,...
3
Стихотворение М. Лермонтова И скучно и грустно несколько согласованных и несогласованных...
2
Какими были права русского населения под главенством литовского князя...
1
Сумма первых n членов арифметической прогрессии вычисляется по формуле Sn=(a1+an)2⋅n....
1
Проанализируйте причины размещения в вашем регионе (Карагандинская область)...
2
#include <iostream>
using namespace std;
int main()
{
int size;
cin >> size;
int *a = new int[size];
for (int i = 0; i < size; i++)
{
cin >> a[i];
}
for (int i = 0; i < size; i++)
{
for (int j = size - 1; j > i; j--)
{
if (a[j] < a[j - 1])
{
swap (a[j], a[j - 1]);
}
}
}
for (int i = 0; i < size; i++)
{
cout << a[i] << ' ';
}
return 0;
}