Составить программу для перевода суммы из долларов в рубли. Вводиться текущий курс доллара и сумма в долларах. Результат должен выводиться в денежном формате 345 РУБ 40 КОП ПАСКАЛЬ

Руслантопчик Руслантопчик    1   25.03.2021 07:30    36

Ответы

var

kurs, summa, rub: double;

begin

readln(kurs, summa);

rub := kurs * summa;

writeln(trunc(rub), ' РУБ ', (frac(rub) * 100):2:0, ' КОП');

end.

Объяснение:

Получаем два числа, затем перемножаем курс на сумму в долларах, чтобы получить рубли и затем выводим в нужном формате.  

trunc(a) получает целую часть от числа  

frac(a) получает дробную часть от числа, затем умножаем на 100 для преобразования дробной части в целую(для вывода на экран) (например число 0.22 преобразуется в 22.0) и с :2:0 выводим в формате 2 цифры до запятой и 0 после.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика