Составить программу для паскаля.1)определить количество трехзначных чисел сума цифр которых равна числу n.2)дано натуральное число n.составить программу меняющихся местами первую и последнюю цифру.

Duka2003 Duka2003    2   03.08.2019 21:50    0

Ответы
evasoksoksok evasoksoksok  03.10.2020 20:56
1)
var  s: string;
  i, n,c: integer;
begin
  read(n);
  for i := 100 to 999 do
  begin
    s:=inttostr(i);
    c:=(strtoint(s[1])+strtoint(s[2])+strtoint(s[3]));
    if(n=c)then writeln(s);
  end;
end.

2)
var  s: string;
begin
  read(s);
  swap(s[1],s[s.Length]);
  write(s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика