Составить программу для нахождения нод десяти двухзначных чисел. паскаль.

are0t are0t    2   28.08.2019 15:00    1

Ответы
alka231282 alka231282  03.08.2020 10:49
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

function gcd(a,b:integer):integer; // НОД
begin
  while b<>0 do begin a:=a mod b; Swap(a,b) end;
  Result:=a
end;

begin
  var a:=ReadArrInteger('Введите 10 натуральных двухзначных чисел:',10);
  var g:=gcd(a[0],a[1]);
  for var i:=2 to 9 do g:=gcd(g,a[i]);
  Writeln('НОД=',g)
end.

Пример
Введите 10 натуральных двухзначных чисел: 38 42 56 82 96 32 18 40 58 90
НОД=2
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика