Составить программу для нахождения 1 наименьшего из 4 чисел, после чего умножить его на 2

НАТАШАПРОСТОКВАША НАТАШАПРОСТОКВАША    2   26.04.2021 19:58    0

Ответы
Apple008 Apple008  26.04.2021 20:00

uses crt ;

function min ( a , b :real ) :real;

begin

if a<b then min := a

else min := b ;

end;

var x , y , z , t :real;

begin

clrscr ;

writeln ( 'Введите 4 числа:' ) ;

readln ( x , y , z , t ) ;

write ( 'Минимальное=' , min( min( x , y ) , min( z , t )) : 0 : 2 ) ;

ПОКАЗАТЬ ОТВЕТЫ
Werty0 Werty0  26.04.2021 20:00

Приведу пример на Haskell

main :: IO ()main = do  a <- read $ getLine :: IO Int  b <- read $ getLine :: IO Int  c <- read $ getLine :: IO Int  d <- read $ getLine :: IO Int  print $ 2 * minimum [a, b, c, d]
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика