Составить программу для c++ "ввести возраст человека и вывести его вместе со словом год,года,лет(пример вам 1 год,вам 2 года,вам 55 лет)

ksushaksenia11 ksushaksenia11    3   21.07.2019 21:20    4

Ответы
anyutra anyutra  03.10.2020 09:58
#include <iostream>
int main()
{
    using namespace std;
    system("chcp 1251 > nul"); //для кириллицы
    int age;
    cout << "Введите возраст: ";
    cin >> age;
    if (age > 4 && age < 21)
         cout << age << " ЛЕТ" << endl;
    else if (age % 10 == 1)
        cout << age << " ГОД" << endl;
    else if (age % 10 > 1 && age % 10 < 5)
        cout << age << " ГОДА" << endl;
    else
        cout << age << " ЛЕТ" << endl;
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика