Составить программу 1. нужна программа на тему алгоритма евклида, составьте ,чтобы в паскаль её забить. программа для нахождения наибольшего общего делителя.

mrdrozdovoy228 mrdrozdovoy228    2   25.07.2019 09:40    1

Ответы
АрзуНаз АрзуНаз  24.09.2020 12:07
//Pascal ABC.NET v3.1 сборка 1172

var
  a, b, nod: integer;

begin
  read(a, b);
  while a * b <> 0 do
    if a > b then a := a mod b
    else b := b mod a;
  nod := a + b;
  writeln(nod);
end.

Пример ввода:
1071
462
Пример вывода:
21
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика