Составить блок-схему и написать программу в эвм вводятся по очереди координаты n точек. определить, сколько из них попадает в круг радиусом r с центром в точке (a,b).
Блок-схема - в прилагаемом файле. Программа: var n,r,a,b,k,x,y,i:integer; begin readln(n,r,a,b); k:=0; for i:=1 to n do begin readln(x,y); if sqr(x-a)+sqr(y-b)<r*r then k:=k+1; end; writeln('k = ',k); end.
Программа:
var n,r,a,b,k,x,y,i:integer;
begin
readln(n,r,a,b);
k:=0;
for i:=1 to n do
begin
readln(x,y);
if sqr(x-a)+sqr(y-b)<r*r then k:=k+1;
end;
writeln('k = ',k);
end.
Пример:
3 4 1 1
2 2
-2 -3
0 0
k = 2