Составить алгоритм и написать программу позволяющую найти сумму элементов массива с четными номерами содержащего n элементов заполнение массива организовать натуральными числами в порядке убывания надо

CheburekTadjik2005 CheburekTadjik2005    2   19.09.2019 18:10    1

Ответы
Anuraoaoap Anuraoaoap  01.09.2020 18:52
Блок-схема - в прилагаемом файле.
Программа:
const n=10;
var a:array[1..n] of integer;
s,i:integer;
begin
for i:=1 to n do begin
 a[i]:=n-i+1;
 write(a[i],' ');
 end;
writeln;
s:=0;
for i:=1 to n div 2 do s:=s+a[2*i];
writeln('s = ',s);
end.

Результат:
10 9 8 7 6 5 4 3 2 1
s = 25
Составить алгоритм и написать программу позволяющую найти сумму элементов массива с четными номерами
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика