Составить алгоритм и написать программу для решение с использованием двумерных массивов и конструкций цикла в цикле: вычислить сумму положительных элементов матрицы а (10х10), расположенных над главной диагональю. индекс номера строки i изменяется от 1 до 9, а индекс номера столбца j изменяется от –i+1 до 10.

zoziev2014 zoziev2014    1   11.06.2019 11:30    0

Ответы
annachanskp06yi3 annachanskp06yi3  09.07.2020 12:57
Var a:array[1..10,1..10] of integer;
i,j,sum,np: integer;
begin
for i:=1 to 10 do 
 for j:=1 to 10 do readln(a[i,j]);
sum:=0;
for np:=1 to 9 do begin
 i:=np; 
 for j:=1 to np do begin 
  if a[i,j]>0 then sum:=sum+a[i,j]; 
  i:=i-1; 
 end;
end; 
writeln('Сумма элементов, расположенных выше главной диагонали равна ',sum);
readln
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика