Склавиатуры вводится n чисел. написать программу, которая определяет количество отрицательных, количество положительных и количество нулей среди введённых чисел. значение n также вводится с клавиатуры. язык с++

Nastya3748 Nastya3748    1   02.09.2019 08:50    1

Ответы
728099 728099  06.10.2020 11:31
#include<iostream>
using namespace std;

int main()
{
    int n, A, P = 0, O = 0, N = 0;
    cout << "n = ", cin >> n;
    for (int i = 0; i < n; i++)
    {
        cin >> A;
        if (A > 0) P++;
        else if (A < 0) O++;
             else N++;
    }
    cout << "( < 0): " << O;
    cout << "\n( = 0): " << N;
    cout << "\n( > 0): " << P;
    return 0;
}
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика