Синформатикой: написать программу, которая в массиве размерностью в 10 на 12 находит сумму: 1)всех элементов массива. 2) каждого столбца. 3) каждой строки. 10

vaniafc007 vaniafc007    2   02.03.2019 17:50    2

Ответы
сабина422 сабина422  23.05.2020 22:20

const m=10; n=12;
var a:array [1..m,1..n] of integer;
i,j:integer;
sob:integer;
sst:array[1..n]of integer;
sstr:array[1..m]of integer;
begin
randomize;
for i:=1 to m do begin
for j:=1 to n do begin
a[i,j]:=random(10);
write(a[i,j]:3);
end;
writeln;
end;
sob:=0;
for i:=1 to m do begin
for j:=1 to n do begin
sob:=sob+a[i,j];
end;
end;
writeln('сумма всех элементов массива = ', sob);
writeln;
writeln;
for i:=1 to m do begin
sstr[i]:=0;
for j:=1 to n do begin
sstr[i]:=sstr[i]+a[i,j];
end;
end;
writeln('сумма элементов построчно');
for i:=1 to m do write(sstr[i]:3);
writeln;
writeln;
for j:=1 to n do begin
sst[j]:=0;
for i:=1 to m do begin
sst[j]:=sst[j]+a[i,j];
end;
end;
writeln('сумма элементов по столбцам');
for j:=1 to n do write(sst[j]:3);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика