Сильно на языке pascalabc.net: 1)определить значение z = max (a, 2b) • max (2a-b, b),где max (x, y) есть максимальное из чисел х, у. при решении определить и использовать функцию max.выполнить отладку программы с заходом в каждую из подпрограмм. 2)найти сумму четных элементов массива целых чисел. массив должен вводится во время работы программы.выполнить отладку программы с заходом в каждую из подпрограмм. 3)написать программу, которая вводит двумерный массив а(n,m) и заменяет все отрицательные элементы на 0.
1) хотя не понятно зачем изобретать велосипед
function max(a, b: integer): integer;
begin
max := a;
if b > a then
max := b;
end;
begin
var a:=ReadInteger('a =');
var b:=ReadInteger('b =');
writeln(max(a, 2 * b) * max(2 * a - b, b));
end.
2)
const
handfree = false;
begin
var a:= new integer[ReadInteger('n =')];
if handfree then
a := ArrRandomInteger(a.Length, -50, 50)
else
a := ReadArrInteger(a.Length);
writeln('Array:');
a.Println;
writeln('Sum of odds by value = ', a.Where(x -> x mod 2 = 0).Sum);
writeln('Sum of odds by position = ', a.Slice(0, 2).Sum);
end.
3)
const
n = 5;
m = 6;
handsfree = false;
begin
var a := new integer[n, m];
writeln('Данные матрицы:');
for var i := a.GetLowerBound(0) to a.GetUpperBound(0) do
begin
for var j := a.GetLowerBound(1) to a.GetUpperBound(1) do
if handsfree then begin
a[i, j] := random(-50, 50);
write(a[i, j]:4, ' ')
end
else
read(a[i, j]);
writeln;
end;
writeln('Вывод:');
for var i := a.GetLowerBound(0) to a.GetUpperBound(0) do
begin
for var j := a.GetLowerBound(1) to a.GetUpperBound(1) do
begin
if a[i, j] < 0 then a[i, j] := 0;
write(a[i, j]:4, ' ');
end;
writeln;
end;
end.