tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Сформировать массив содержащий
Сформировать массив содержащий 15 элементов с датчика случайных чисел . получите новый массив каждый элемент которого равен удвоенному соответствующиму элементу исходного массива
kiraganziy
3 13.09.2019 01:20
7
Ответы
irina83soft071
07.10.2020 10:50
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(15,-50,50); a.Println;
var b:=a.Select(t->2*t).ToArray; b.Println
end.
Пример
28 -22 -43 -36 -20 -21 36 -26 48 25 -31 -29 8 -35 17
56 -44 -86 -72 -40 -42 72 -52 96 50 -62 -58 16 -70 34
ПОКАЗАТЬ ОТВЕТЫ
Jeka990
07.10.2020 10:50
Const Sz = 100; // Размер массива
var
a,b: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i: integer;
begin
N := 20;
for i:=1 to N do begin
a[i] := Random(100);
b[i]:=a[i]*2;
writeln('Элементы массива: ');
for i:=1 to N do
writeln(a[i],' ',b[i]);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Clook2023
25.06.2019 15:10
Определите количество комбинации для логического выражения из 4 переменных...
dianakli
25.06.2019 15:10
Построить таблицу для функции y=ax+b где x принимает значение 0,5; 1; 1,5; 2; 2,5; 3 паскаль while...
ВикторияТуп
12.09.2019 03:00
Посчитайте ,только подробно расписать 240бит= мб 780кб= гб 250гб= кб 4гб+256мб= кб...
НезнайкаФдпун
12.09.2019 03:00
Превратить функцию в процедуру function koldel(n: integer): integer; var i,k: integer; begin k: =0; for i: =1 to n do if n mod i=0 then k: =k+1; koldel: =k; end; var m,n,i: longint;...
тата238
12.09.2019 03:00
Напишите программу на языке си. дана последовательность целых чисел и количество членов в последовательности. вычислите есть ли число 0 в поледовательности...
Zlyka11
12.09.2019 03:00
9класс. составить программу перевода количества сантиметров в метры и километры. (паскаль) чтобы, например, если ввести 100 см, то выдавалось бы 1 метр и 0,001 километр....
Artem20032003
12.09.2019 01:03
Вид информации, которую нельзя сохранить и передать....
макс3106
12.09.2019 03:10
Несложно ! 1. даны два случайных числа. определить а) наибольшее б) наименьшее 2. даны три числа. вывести а) наибольшее б) наименьшее паскаль...
Frampo228
06.12.2020 23:21
1. Відкрийте вказаний учителем файл (наприклад, Розділ7\Практична15\зразок пр15.xlsx). 2. На аркуші Аркуш1 подано таблицю показників лічильника електроенергії за кожен місяць...
Токаарічіна
06.12.2020 23:20
Увеличить значение первого числа ...
Популярные вопросы
1) Период Диф. решётки равен 2мм, на расстоянии 4м стоит экран, найти ширину...
3
решить за 1 пример только правильно...
1
английский 8 класс 2,3 задание...
3
С 60 гусей получили 2 кг пуха сколько Пуха можно получить с 180 гусей...
3
При ожогах щелочами кожу сначала промыть водой, затем нейтрализовать 1% раствором...
3
Используя Гражданский кодекс РФ и трудовой кодекс РФ Проанализируйте последствия...
3
1. Начертите отрезок длиной5 cm. Найдите егоось симметрии....
3
Какую телевизионную программу вы смотрите и почему ?...
3
1.На каком расстоянии от Земли астероид Апофис пролетит мимо? 2.На каком созвездии...
1
Расскрыть скобки:Надеть (не)красивый плащ...
1
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(15,-50,50); a.Println;
var b:=a.Select(t->2*t).ToArray; b.Println
end.
Пример
28 -22 -43 -36 -20 -21 36 -26 48 25 -31 -29 8 -35 17
56 -44 -86 -72 -40 -42 72 -52 96 50 -62 -58 16 -70 34
var
a,b: array [1..Sz] of integer;
N: integer; // Количество элементов в массиве
i: integer;
begin
N := 20;
for i:=1 to N do begin
a[i] := Random(100);
b[i]:=a[i]*2;
writeln('Элементы массива: ');
for i:=1 to N do
writeln(a[i],' ',b[i]);
end.