tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Сформировать массив из 13
Сформировать массив из 13 целых чисел из интервала от -15 до 25, подсчитать сумму положительных из них,иподсчитать произведение массива кратных 3, отсортировать массив в порядке возрастания
zeca123415
3 24.07.2019 13:50
0
Ответы
MSZaDrotE
07.09.2020 19:27
// PascalABC.NET 3.1, сборка 1211 от 31.03.2016
begin
var a:=ArrRandom(13,-15,25);
a.Println;
Writeln('Сумма положительных ',a.Where(x->x>0).Sum);
Writeln('Произведение кратных трем ',
a.Where(x->x mod 3=0).Aggregate(1,(p,n)->p*n));
a.Sorted.Println
end.
Тестовое решение:
21 -5 14 -6 -6 -3 -11 -14 17 -7 -11 -5 21
Сумма положительных 73
Произведение кратных трем -47628
-14 -11 -11 -7 -6 -6 -5 -5 -3 14 17 21 21
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Arystan228
17.09.2019 14:00
Выберите правильные имена переменных, обоснуйте свой выбор почему данная последовательность символов может быть именем переменной, а почему нет. fdgjhdh 12fd gh d r fgj klass7...
ppn01012014
17.09.2019 14:00
Что объединяет попугая, пеликана и пингвина...
anya12345678900
14.11.2020 12:01
вас Заранее большое 8. Найдите ошибки в записи заголовков подпрограмм1) Procedure A (x+y); 2) Procedure A (10);3) Procedure A (X; Y); 4) Procedure A (X: integer, Y: Real, Z: Boolean);5)...
levgoncharenko
14.11.2020 12:00
В питоне! Ввести с клавиатуры натуральное число и найти сумму значений его цифр. Пример: Введите число: 1234 Cумма цифр 10 Составьте программу для питона...
Milena200516
24.04.2019 08:30
Составить таблицу истинности -- -- (а+в) * с...
marylps45
21.02.2021 13:33
Запишите на алгориьмическом языке(Паскаль)алгоритм, соответствующий данной блок схеме:...
hippol
29.04.2019 15:07
1)a : = 2; b : = 5; a : = a * 2 div 3; if b a then c : = a - 3 else c : = a + 4; 2)в таблице запросы к поисковому серверу. расположите номера запросов в порядке возрастания количества...
VictorTsoy1962
29.04.2019 15:06
Дана последовательность 10 натуральных чисел. найти среди них количество чётных чисел. нужна программа и блок схема...
Gfykfyj
09.06.2019 21:50
Логическое выражение или укажите его результат(при его однозначности). результат может содержать только операции инверсии, конъюнкции и дизъюнкции. a and b and not c ↔ (not a or...
12323543654
26.01.2021 23:17
8-тапсырма Мәтінде қарамен белгіленген сөйлемді сөздердің байланысу түріне қарай талданыз. (Жұмыр жерді мекендейтін сан мыңдаған тіршілік атауының ішінде Жер-анаға а артық қиянат...
Популярные вопросы
На столе находятся две трехлитровые банки, одна из них наполнена медом другая...
2
Написать уравнение реакции гидролиза целлюлозы. какой фермент участвует в реакции...
2
Определить давление бензина на дно сосуда высотой 50 см....
3
Известно, что sin a = 0,28; cos b = 0,6; a и b - углы первой четверти. установите...
1
Какие особенности дыхания у млекопитающих?...
2
Вiтальне слово на честь героя з твору джури козака швайки...
1
мир же не без добрых людей) составьте синквейн к слову буква ....
3
чудесный доктор как повлияла встреча с доктором на будущую судьбу? ! 25 !...
2
Расскажите, , коротко о правлении александра 1...
1
Торговля, приводящая к односторонней выгоде от сделке...
1
begin
var a:=ArrRandom(13,-15,25);
a.Println;
Writeln('Сумма положительных ',a.Where(x->x>0).Sum);
Writeln('Произведение кратных трем ',
a.Where(x->x mod 3=0).Aggregate(1,(p,n)->p*n));
a.Sorted.Println
end.
Тестовое решение:
21 -5 14 -6 -6 -3 -11 -14 17 -7 -11 -5 21
Сумма положительных 73
Произведение кратных трем -47628
-14 -11 -11 -7 -6 -6 -5 -5 -3 14 17 21 21