Сделать в паскале. составьте программу, которая удаляет из слова x те буквы, которые встречаются в слове z. слова x и z вводятся с клавиатуры.

hhhf1fodjcnj hhhf1fodjcnj    1   29.05.2019 07:10    1

Ответы
Дошик58694 Дошик58694  28.06.2020 01:16
var
x,z:string;
i:integer;
ar:array['а'..'я'] of boolean;
begin
readln(x);
readln(z);

for i:=1 to Length(z) do
  ar[z[i]]:=true;
  for i:=Length(x) downto 1 do
    if (ar[x[i]] = true) then delete(x,i-1,1);   
writeln(x);
end.

Не забудь отметить лучший ответ ;-)
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика