С++ Вам дан фрагмент программы, в котором создается двумерный массив и выводится на экран. Дополните эту программу таким образом, чтобы элементы в каждой строке были равны индексу этой строки.
#include
using namespace std;
int main() {
int n, m;
int arr[100][100];
cin >> n >> m;

// ваш код

for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
cout << arr[i][j] << " ";
}
cout << endl;
}
return 0;
}
Формат входных данных
В единственной строке входных данных вводятся два натуральных числа N и M, не превосходящие 100.

Формат выходных данных
Выведите N строк по M столбцов — заполненный соответствующим образом двумерный массив.

Примечания
Сдавать требуется только указанный фрагмент программы.
входные данные
3 4

10 8
выходные данные
0 0 0 0
1 1 1 1
2 2 2 2

0 0 0 0 0 0 0 0
1 1 1 1 1 1 1 1
2 2 2 2 2 2 2 2
3 3 3 3 3 3 3 3
4 4 4 4 4 4 4 4
5 5 5 5 5 5 5 5
6 6 6 6 6 6 6 6
7 7 7 7 7 7 7 7
8 8 8 8 8 8 8 8
9 9 9 9 9 9 9 9

bomberdire bomberdire    3   20.04.2021 19:49    72

Ответы
yanalatina97 yanalatina97  24.12.2023 12:52
Хорошо, я продемонстрирую вам, как можно дополнить программу, чтобы каждый элемент в каждой строке равнялся индексу этой строки.

```cpp
#include
using namespace std;

int main() {
int n, m;
int arr[100][100];
cin >> n >> m;

// Ваш код
// Инициализируем каждый элемент массива arr[i][j] значением i
for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
arr[i][j] = i;
}
}

for (int i = 0; i < n; i++) {
for (int j = 0; j < m; j++) {
cout << arr[i][j] << " ";
}
cout << endl;
}
return 0;
}
```

1. Сначала объявляем переменные `n` и `m`, которые будут хранить количество строк и столбцов массива соответственно.
2. Затем объявляем двумерный массив `arr` размером 100 на 100.
3. Вводим значения `n` и `m` с помощью `cin`.
4. Затем инициализируем каждый элемент массива `arr[i][j]` значением `i` с помощью вложенных циклов. Переменная `i` будет использоваться для прохода по строкам, а переменная `j` - для прохода по столбцам. Таким образом, каждый элемент в каждой строке будет равняться индексу этой строки.
5. После инициализации массива используем вложенные циклы для вывода каждого элемента массива `arr[i][j]`.
6. После вывода каждой строки используем `cout << endl;` для перехода на новую строку.

Теперь программа будет выводить двумерный массив, в котором каждый элемент в каждой строке равен индексу этой строки.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика