с++ решите задачу Напишите программу которая сортирует список слов с добавленной нумерацией.Количество слов известно.
Входные данные:
В первой строке вводится количество слов N (1<=N<=1000)В следующих N строках вводятся слова,по одному в строке.Перед каждым словом стоит порядковый номер ,за которым следует точка и пробел.
Выходные данные:
Программа должна вывести список слов , отсортированных по алфавиту с нумерацией.
Примеры;
Входные данные;
4.
1. zoo
2. apple
3. nokia
4. horse
Выходные данные
1. apple
2. horse
3. nokia
4. zoo


с++ решите задачу Напишите программу которая сортирует список слов с добавленной нумерацией.Количест

vintageflower vintageflower    2   06.11.2021 09:46    16

Ответы
flillen flillen  06.11.2021 09:50

#include <iostream>

#include <algorithm>  

using namespace std;

int main() {

   system("color A");

   string arr[11], a;

   int size = 0;

   while (cin >> a) {

       if (a == "s") break;  

       //'старт' для начала определения слов служит буква 's'

       arr[size++] = a;  // слова в массив

   }

   sort(arr, arr + size); // Сортировка

   for (int i = 0; i < size; i++) cout << arr[i] << endl;

   return 0;

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика