с решением , на паскале:
на вход программе подается три различных целых числа. вывести на экран, как соотносится третье введённое число относительно первых двух: "больше" (если оно больше обоих первых чисел), "меньше" (если оно меньше обоих первых чисел) или "между" (если оно больше одного, но меньше другого). запрещается пользоваться арифметическими операциями. дополнительный получит программа, выполняющая в худшем случае не более 3-сравнений.

ЮляФранк2105 ЮляФранк2105    1   24.12.2019 00:51    0

Ответы
RonnieHolmes RonnieHolmes  27.08.2020 18:52

PascalABC.NET

begin

 var (a, b, c) := ReadInteger3;

 if a > c then

   if b > c then

     Write('меньше')

   else

     Write('между')

 else if b > c then

   Write('между')

 else

   Write('больше')

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика