с программированием. Нужно написать программу по заданию, в которой будет ПОДПРОГРАММА и ОСНОВНАЯ ПРОГРАММА Я написала обычную программу, но не знаю как переделать ее под задание const N = 10;
var
a: array[1..N] of integer;
i: integer;
sr: real;
sum: integer;
begin
randomize;
for i:=1 to N do a[i]:=random(50)+1;
sum := 0;
for i:=1 to N do sum := sum + a[i];
sr:= sum/N;
for i:=1 to N do write(a[i]:3);
writeln;
writeln('Среднее арифм.: ',sr:4:2);
for i:=1 to N do if a[i]>sr then
write(sr:4:2, ' ')
else
write(a[i], ' ');
writeln;
end.


с программированием. Нужно написать программу по заданию, в которой будет ПОДПРОГРАММА и ОСНОВНАЯ ПР

driftsmuk1 driftsmuk1    1   12.04.2021 11:53    1

Другие вопросы по теме Информатика